You are viewing the legacy StackPath SecureCDN Status page. Please use status.stackpath.com if you signed up after July 1, 2018.

StackPath Secured CDN Control Panel issues
Incident Report for StackPath SecureCDN
Resolved
This incident has been resolved.
Posted Nov 28, 2019 - 02:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2019 - 00:09 UTC
Investigating
StackPath Secured CDN is investigating an issue with the Control Portal. Our engineers are working to resolve the issue and restore UI access.

If you have questions, our Support team is available 24/7 through live chat, ticket or phone at 1-800-570-2253
Posted Nov 27, 2019 - 21:59 UTC
This incident affected: System (Control Panel).