You are viewing the legacy StackPath SecureCDN Status page. Please use status.stackpath.com if you signed up after July 1, 2018.

SSL certificate issues
Incident Report for StackPath SecureCDN
Resolved
We have confirmed the updated certificate is functioning and all impact to customers has been resolved.
Posted Aug 08, 2020 - 05:31 UTC
Monitoring
We have pushed an update to the shared certificate. We are now confirming that the issue has been resolved for all customers.
Posted Aug 08, 2020 - 04:38 UTC
Identified
We have identified the issue to be related to our SSL certificate. We are continuing to work on the issue and deploy a fix.
Posted Aug 08, 2020 - 02:38 UTC
Investigating
StackPath is currently experiencing issues with SSL certificate. Our engineers are working to resolve this matter with further updates to follow as they become available.

If you have questions, our Support team is available 24/7 through live chat or phone at 1-800-570-2253.
Posted Aug 08, 2020 - 01:28 UTC
This incident affected: System (Control Panel).